题目

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​ ]), followed by N integer distances D​1​​ D​2 ⋯ D​N​​ , where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

解析

题目:

n个节点形成一个圆环,编号从1n,按顺序给出 1-2距离2-3距离、...、n-1距离。给出m对节点i,j,要求输出i,j之间的最短距离。

思路:

  • 在获取输入的同时计算出每个结点到第一个结点的距离,并将它存放在数组dis[]中,即dis[n]表示节点n到节点1的顺序方向对应的距离,dis[n+1]表示整个环的距离和。
  • 任意两点的距离要么环的"劣弧",要么是环的"优弧",这里先求按顺序由ab的距离(a<b),也就是dis[b]-dis[a],另一端距离用圆环总长度(dis[n+1])减去这里求的距离,比较两者取最小值。
  • 圆环总长度小于107,那么距离值可以定义为int.

代码

#include <iostream>
#include <vector>
using namespace std;

int main() {
    int n, dis[100001], temp;
    cin >> n;
    // 节点编号从1开始,
    // 输入数据是 1-2距离,2-3距离,...n-1距离
    for (int i = 1; i <= n; ++i) {
        cin >> temp;
        // dis[i]保存从节点1到节点i的距离,假如有n和节点,那么dis[n + 1] 就是整个环的距离和
        if (i == 1) dis[i + 1] = temp;
        else dis[i + 1] = dis[i] + temp;
    }
    int m, a, b;
    cin >> m;
    while (m-- > 0) {
        cin >> a >> b;
        // 保证按顺序小,大
        if (a > b) swap(a, b);
        // “劣弧”对应的长度
        temp = dis[b] - dis[a];
        // dis[n + 1] - temp 是 “优弧”对应的长度,取较小的那个
        cout << min(temp, dis[n + 1] - temp) << endl;
    }

    return 0;
}
打赏
支付宝 微信
上一篇 下一篇